Update-Blockade: Microsoft zieht Patch für Windows 7 und 8.1 zurück

Microsoft hat das am Dienstag zum regulären Patch-Day veröffentlichte Update für Windows 7 und Windows 8.1 nun für einige Nutzer wieder zurückgezogen. Nutzer, die Sophos Endpoint Security installiert haben, hatten zuvor von massiven Problemen ... mehr... Microsoft Patch Day, Windows Logo, Pflaster Bildquelle: PC Games Patch-Day, Microsoft Patch Day, Windows Logo, Pflaster Patch-Day, Microsoft Patch Day, Windows Logo, Pflaster PC Games

Diese Nachricht vollständig anzeigen.

Jetzt einen Kommentar schreiben
 
Lass mich raten, liegt mal wieder daran, dass der AV an irgendwelchen undokumentierten Stellen im Kernel rumfurwerkelt? Wenn's im abgesicherten Modus geht, ist das ein recht deutliches Indiz.
 
@Kirill: Das mag ja sein, aber wie kann es sein, dass offenbar kein Microsoft-Tester fremde Antivirensoftware nutzt?

Eben das ist das Kuriose: Die allermeisten Bugs der letzten Jahre hätten beim Testen eigentlich auffallen müssen.
 
@BartS: muss denn Microsoft sowas mit allen möglichen AV Programmen testen, obwohl deren Entwickler weiterhin nicht auf die von MS bereitgestellten Schnittstellen setzen, sondern am System vorbei mit irgendwelchen Treibern am System rumfummeln?
 
@der_ingo: Ich nehme an er redet eher vom Insider-Programm
 
@BartS: Vor 10 Jahren hätte ich dir noch vollkommen zugestimmt, inzwischen ist der Windows Defender jedoch so gut geworden, dass man zumindest als Privatperson nicht mehr zwingend eine Drittanbietersoftware benötigt - also werden hier auch die wenigsten noch für eine AV-Software Geld ausgeben. Dass Problem fällt dann erst auf wenn Firmen mit ihrer Endpointprotection-software updaten und etwas querschießt.
 
@BartS: Ja, wenn Sophos ordentlich getestet hätte, wäre das nicht passiert.
 
@rallef: Doch, da ich Sophos gar nicht nutze.
 
@BartS: du wirst ein anderes der betroffenen Softwarepakete nutzen.
 
@BartS: Gegenfrage: Warum greift fremde AV-Software derart tief in den Kernel ein? Seit Vista gibt es eine stabile API/ABI aber nein, das ist für Luschen. Die coolen Kids graben lieber in internen Datenstrukturen rum, sodass MS die nicht verbessern oder fehlerbereinigen kann.
 
Unter Windows 10 auch, bin selbst betroffen.
 
Wir haben bei uns in der Firma 14 Rechner, die noch nicht auf Windows 10 umgestellt sind und die waren heute morgen alle von dem Problem betroffen. Wir verwenden den Sophos Endpoint Virenscanner.

Die oben beschriebene Lösung hat das Problem bei uns behoben.
 
Abhilfe bei Windows Server 2012R2 mit installiertem Exchange 2013 in virtueller Umgebung auf einem Host mit AMD EPYC CPU:

Auch ohne Vorhandensein irgendwelcher Antivirensoftware von Drittherstellern startete der Server nicht mehr auf Hyper-V nach Installation der unsäglichen Updates. (Gilt nur für AMD Epyc Hosts, auf Intels XEON Hosts keine Probleme!)

Workaround:

Mit Ausnahme der virtuellen Startfestplatte alle anderen virtuellen Festplatten an dem 2012R2 Gast abklemmen. (Backup Festplatte nicht vergessen!)

Dann den Gast auf Hyper-V starten. Wenn ca. 15 Sekunden rum sind, d.h. noch *vor* der endgültigen Installation der Updates (vor dem Hinweis: Schalten Sie den PC nicht aus) schnell die zuvor abgeklemmten Platten wieder verbinden.

Der Gast erhält seine Windows Updates und das Exchange Security Update für CU 22 ordnungsgemäß installiert.

Auf die Idee, alle Platten mit Ausnahme der Startfestplatte vor dem Neustart abzuklemmen, musste in unserer IT auch erst einmal Jemand kommen...

G.-J.
 
@Gajus-Julius: ...das ist kein Workaround sondern Pfusch... MS GO HOME!
 
lol und alle Jahre wieder... deshalb wird immer erst ne Woche oder 2 gewartet bevor der neueste Patch draufkommt...
 
@legalxpuser: Ich habe bisher noch an Besserung geglaubt, aber nachdem ich jetzt innerhalb eines Jahres gleich von zwei gravierenden Bugs nach Installation von Windows-Updates betroffen war, tendiere ich mittlerweile auch dazu.
 
Die angebotenen Lösungen finde ich MAGA-genial: Wenn Win7/8 nicht mehr startet, einfach stattdessen Win7/8 benutzen/hochfahren!

Danke Donald!!!
 
Windows 10 und Avira sind auch betroffen. Außerdem die dazugehörigen Servervarianten.
 
wir haben hier das Problem das wir noch nicht mal in den abgesicherten Modus rein kommen um den Workaroud anzuwenden (w7/64)
 
@x-5: Etwas genauer bitte damit man helfen kann.

Welche Methode habt ihr ausprobiert? Beim booten immer wieder F8 gedrückt? (Falls ja, was funktioniert nicht?
Falls ihr noch in Windows reinkommt, könnt ihr sonst auch win+r drücken und "msconfig" eingeben und unter start abgesicherter Modus wählen.

Falls das alles nichts bringt kann ich euch sonst auch einen anderen Workaround schreiben, wie ihr das Update über die Eingabeaufforderung wieder entfernt (geht selbst von einem Installationsdatenträger aus, falls ihr sonst nirgendwo mehr reinkommt).
 
Ja mit F8 ins Auswahlmenü. Wenn man dann versucht sich im abgesicherten Modus als Admin anzumelden, hat es den Anschein das es funktioniert, doch nach ca. 2-3 Sekunden bootet der Rechner neu und läuft wieder in Schleife (Updates werden konfiguriert, nicht ausschalten). Unter allen Modis, normaler abgesicherter Modus, mit Netzwerk, mit Eingabeaufforderung. Mehrmals hintereinander versucht, keine Möglichkeit in den abgesicherten Modus zu gelangen.
 
@x-5: Ok, dann wäre es wahrscheinlich wirklich das einfachste, das Update über einen Installationsdatenträger zu deinstallieren, falls ihr einen solchen zur Hand habt.

Von Installationsdatenträger booten. Sobald fertig gebootet ist öffnet ihr mit Shift+F10 die Eingabeaufforderung.
Als erstes gilt es rauszufinden, unter welchem Laufwerksbuchstaben der Installationsdatenträger die Windowspartition eingehängt hat:

diskpart
list volume

(hier wird eine Liste aller Partitionen ausgegeben, macht hier die Windowspartition ausfindig.
Anschließend verlasst ihr diskpart wieder mit:)

exit

(Im folgenden nehme ich an, dass die Windowspartition unter D:\ eingehängt wurde, diesen
Pfad gilt es ggfs. anzupassen.)

dism /image:D:\ /get-packages /format:table

(dies gibt eine liste der installierten updates aus. Richtet euch hier nach dem
Installationsdatum. Markiert mit der Maus den unter Paketidentität angegebenen Namen des
Pakets, ein rechtsklick kopiert diesen in die Zwischenablage)

dism /image:D:\ /remove-package /packagename:

(hinter "packagename:" einfach mit der Maus rechtsklicken um den paketnamen aus der
Zwischenablage einzufügen.)
 
@Thomas-K: OK, Danke, teste ich morgen mal aus
 
@Thomas-K: Ich kam mit dem Paketnamen nicht klar, er wurde vollständig kopiert nicht akzeptiert, nur der Name 'KB499...' auch nicht, es gab auch keine spezielle Unterkategorie, oder Einordnung nach Paketidentität. Nach ~10-15 Versuchen kam ich dann doch in den abgesicherten Modus. Jetzt habe wir auf zwei Rechnern das Problem dass das Hotfix zwar deinstalliert wird, dann nach dem Neustart die Änderungen wieder rückgängig gemacht werden weil ein Fehler aufgetreten ist. Ich hatte zuvor Sophos komplett deinstalliert um sicher zu sein das er nicht dazwischen funkt. Derzeit weiß ich nicht wir wir weiter kommen sollen.
 
@x-5: Aus Aussagen wie "er wurde nicht akzeptiert" kann man aus der Ferne schlecht beurteilen was nicht funktioniert - bitte zukünftig immer die genaue Fehlermeldung, dir da angezeigt wird mitposten.

Heisst du kommst aber jetzt schon mal ins System wieder rein, damit gibt es wieder mehr Möglichkeiten.

Bitte als erstes mal die von Microsoft bereitgestellte Tour zur Behebung von Update-Fehlern durch machen:
https://support.microsoft.com/de-de/help/10164/fix-windows-update-errors
 
@Thomas-K: sorry, klar. Ich kann mich leider nicht mehr an den genau Text erinnern, war so was wie , Paket nicht gefunden. Ich denke ich darf nicht den ganzen Namen kopieren? 'Package_fuer_...KB449....1.6.2.1' oder so ähnlich. Die Fehlermeldung besagte dass das Paket unter diesem Namen nicht gefunden werden konnte. Mittlerweile kommen wir auf den meisten Rechnern ins System. Besten Dank für den Link!, werde ich nächste Woche abarbeiten
 
@x-5: Nur mal so eine Frage am Rande... auch um den weiteren Zeitaufwand, den ihr da reinsteckt, möglichst gering zu halten: Ein Upgrade auf Windows 10 kommt für euch überhaupt nicht in Frage?

Der Support für Windows 7 läuft ja bald aus und ein Windows 11 wird es nicht geben, sprich irgendwann werdet ihr ohnehin umstellen müssen . Noch geht das Upgrade kostenlos und die Fehler wären damit auch gleich behoben.
 
Windows 7 & Avast auch betroffen.
"Lösung" nachdem ich Stunden wartete, so wie es in etlichen Tipps empfohlen wurde hab ich den Stecker gezogen;
Abgesichert gebootet;
letzten Systemwiederherstellungspunkt drauf;
Windows Update vorerst auf Manuell;
FETTISCH ;-) ...vorerst

LG Michael
 
Ich hatte mit Kaspersky Antivirus in der letzten Zeit nur Blue Screens und Abstürze. dann habe ich es entfernt und es gab keine Blue Screens und Abstürze mehr. Dann installierte ich es wieder , und es war noch schlimmer als zuvor. Deshalb habe ich jetzt einfreies AV, und den Kasper heruntergeschmissen. Was nutzt mir ein AV- Programm, das auch noch teuer war, wenn es schlimmer als ein Virus wird/ist? Wenn es dieses update oder das Andere still und klammheimlich nicht zulässt und man rätselraten muss? Ich bin leider kein IT- Experte oder Programierer, deshalb vermutete ich immer auch andere Probleme dahinter. Heraus kommt nun, das ich der Registry geschadet habe, und keine updates mehr machen kann.
Kommentar abgeben Netiquette beachten!
Einloggen