Microsoft .NET Framework 3.5, 3.0 SP1 und 2.0 SP1

Systemprogramme Mit dem .NET Framework bietet Microsoft eine .NET-basierte Programmierschnittstelle an, die für alle aktuellen Windows-Systeme gedacht ist. Sie erlaubt die Ausführung von Software, die in verschiedenen Programmiersprachen entwickelt wurden. mehr...

Diese Nachricht vollständig anzeigen.

Jetzt einen Kommentar schreiben
 
Wunderbar. Endlich mal ein guter Mittwoch.
 
Hä? SP1 für 2.0 und 3.0?

Ist die 3.5 nicht eine neuere Version? Wozu braucht man noch den alten Krams und wieso werden da SPs rausgebracht?
 
@medrival: Weil es Programmie gibt die die alten Net frameworks brauchen. Ausserdem lösst man auch Schwachstellen oder bräuchte das "alte" und bessere Windows XP noch ein 3. Service Pack?
 
@ overdriverdh21: Das SP3 für XP ist schon längst fertig und kommt vorraussichtlich Anfang 2008! Siehe : http://www.winfuture.de/magazin/Windows-XP-Service-Pack-3-Die-Neuerungen-und-Vernderungen-34838-1.html
 
@Outlow: Fertig ist das noch nicht. RC1 Status.
 
Schnelltest: Ich hab das .NET 2.0 deinstalliert, nLite (braucht 2.0) funktionierte nicht mehr. Nachdem ich 3.5 installierte ging es wieder.
 
Ich hatte die 3.0 = 2.5 genannt und die 3.5 = 3.0 genannt. Wäre meines Erachtens nach richtiger von den Funktionen, da 3.0 einfach zusätzliche Funktionen beinhaltet und zB VS2008 komplett auf 3.5 aufsetzt. Endlich LINQ- freu!
 
@webmaster_sod: Die Version 3.0 enthält die Version 2.0. Die Version 3.5 enthält die Versionen 3.0 und 2.0. Die Versionen 1.1 und 1.0 waren dagegen eigenständig. Braucht man 2.0, 3.0 und 3.5, reicht es die 3.5 zu installieren.
 
@medrival: genauso habe ich auch reagiert als mir jemand sagte das er das .NET-Framework nicht mag und deswegen auch immernoch ohne programmiert.

Mir ist es mitllerweile auch nicht klar, warum es Entwickler gibt die noch ohne .NET entwickeln. Aber ich kann es verstehen das nicht alle Entwickler sofort auf das .NET 3.0 wechseln. Ich nutze immernoch .NET 2.0 weil es mit dem VS2k5 nutzbar ist. AFAIK ist das .NET 3.0 aber nicht!
 
@gr4y: Es gibt Aufgaben, für die ist .net schlicht nicht geeignet. Z. B. weil es die nötige Funktionalität nicht bietet (wenn man ständig P/Invoke nutzen muss, kann man auch gleich auf .net verzichten). Oder weil es zu langsam ist (weniger bei der Ausführung, aber beim Programmstart).
Für die Nutzung von .Net 3.0 mit Visual Studio 2005 gibt es übrigens Erweiterungen für VS. Allerdings sind die eher eine Notlösung, der GUI-Editor für XAML ist bspw. eine Katastrophe.
 
Habe jetzt nicht so ganz verstanden, ob das NUR die SPs für das Framework sind oder die Programme MIT den SPs INTEGRIERT...
 
@KirillSp: Bis jetzt gab es nur Version 3.0, die Version 3.5 ist neu und eine Vollversion (deswegen steht da auch ... Final Full... im Dateinamen) und die anderen beiden sind Service Packs (deswegen steht da auch ...Service Pack...).
 
@KirillSp: Die 3.5 ist die DNF Runtime 3.5, die anderen beiden Downloads sind nur die Servicepacks für die älteren DNF Versionen. Die Entwicklungsumgebungen (denke das meinst du mit Programme) sind natürlich nicht dabei, genausowenig wie Kommandozeilencompiler und Headerdateien. Wenn du die haben willst mußt du das .NET Framework SDK laden.
 
Es wäre aber sinnvoller, wenn man auch gleich iwo die Entwicklungsumgebungen (genau das meinte ich mit Programme ^^) bereits mit den SPs (also bereits integriert) runterladen könnte...
 
Enthält das ".NET Framework 3.5 Final Full Redistributable Package" auch die Service Packs für die früheren Versionen oder müssen diese getrennt installiert werden?
 
@finnischeruhu: "Microsoft .NET Framework 3.5 contains many new features building incrementally upon .NET Framework 2.0 and 3.0, and includes .NET Framework 2.0 service pack 1 and .NET Framework 3.0 service pack 1."
 
@ mods:
"IMPORTANT:

* If you have installed earlier pre-release versions of .NET Framework 3.5, then you must uninstall them prior to running this installation by using Add or Remove Programs.
"
Könntet ihr das bitte in der News ergänzen?
 
@finnischeruhu: Wird das nicht bei der Installation ohnehin mitgeteilt?
 
Hat irgend jemand schon den offiziellen und kompletten Changelog gefunden? Danke
 
Also hab mal versucht unter Vista Netframework 3.0 SP1 zu installieren dann sagt er die Version ist nicht gültig für mein Netframework 3.0? 3.5 installiert ohne Probleme! Kann des sein das Vista beim SP1 ausgeschlossen ist und nur für das 3.0 unter XP gilt?
 
@AndyW1978: Was spielt das für eine Rolle? Im .Net 3.5 Paket sind die Versionen 2.0SP1 und 3.0SP1 doch offenbar ohnehin inbegriffen. Also mach einfach 3.5 drauf.
 
@AndyW1978: Man kann sich fragen, warum auf der Download-Seite steht: Supported Operating Systems: Windows Server 2003: Windows XP und du das trotzdem unter Vista probierst...
 
Verstehe nicht warum die nicht nur EINE aktuelle pfelegen und anbieten und damit sollen auch alle (auch die alten laufen können), wie anstatt immer für alle patches zu bringen
 
Muss ich mir das ganze Paket runterladen, wenn ich von 2.0 auf 3.5 aktualisieren möchte?
 
Muss ich jetzt wenn ich meinen Rechner neu installiere nur Net Framework 3.5 installieren oder muss ich den Rest wie 2.0 und 3.0 auch installieren? LG ALEX
 
@friedi: Die Version 3.0 enthält die Version 2.0. Die Version 3.5 enthält die Versionen 3.0 und 2.0. Braucht man 2.0, 3.0 und 3.5, reicht es die 3.5 zu installieren.
 
@friedi: und 3.5 ist nur 100mb groß :) ...ist wie beim flashplugin, geht zack zack. ROFL
 
Erklärt mir das bitte einmal jemand?
Muss man 3.0 und 3.5 installieren?
Beziehungsweise welche davon (außer 2.0) ist die Variante die auf Vista vorinstalliert ist?
 
@Matti-Koopa: Die Version 3.0 enthält die Version 2.0. Die Version 3.5 enthält die Versionen 3.0 und 2.0. Braucht man 2.0, 3.0 und 3.5, reicht es die 3.5 zu installieren. Vista kommt mit 3.0 und damit implizit auch 2.0 daher.
 
Kann man das 3.5er Paket eigentlich in Vista integrieren (richtig slipstreamen)? Oder wird es eh im SP1 mit drin sein? Wenn das SP1 kommt und ich eh eine Slipstream mache, dann will ich auch .Net 3.5 direkt mit in die DVD rein packen.
 
Tja, NET Framework 3.5 Final Full Redistributable Package und NET Framework 3.0 Service Pack 1 Web-Installer funzen bei mir nicht ging jetzt 4 mal auf Fehlerbericht senden.
 
erscheinen die nicht per windows update?? also bei Vista..
 
Werden die neuen Versionen und SPs über Microsoft Update verteilt? Zumindest als empfohlen oder optional?
 
Waaas, knapp 200MB. Mac OS X hat Javascript und ähnlich auch Framework eingbaut. Warum nur Windows niemals?
 
@killax: Kannst du die Frage nochmal so schreiben, dass man sie versteht? Wenn ich dich richtig verstanden habe, willst du wissen warum .net nicht in Windows integriert ist. In Windows Vista ist .net 3.0 integriert.
 
@killax: In den jeweiligen Windows-Versionen, sind immer die .net-Frameworks eingebaut, die zu der entsprechenden Zeit aktuell waren: XP (1.0) 2003 (1.1) Vista (3.0). JavaScript ist nicht drin, weil es zu Rechtsstreitigkeiten kam. Java war bis zum SP1 in Windows XP integriert.
 
Habe eben das NET.Framework 3.5 installiert (2.0 und 3.0 waren schon installiert) ,bin dann auf Windows Update gegangen und habe diese Meldung erhalten.

Vielen Dank für Ihr Interesse an Updates von unserer Site.

Diese Website funktioniert nur mit Microsoft Windows-Betriebssystemen.
Updates für Microsoft-Produkte für Macintosh-Betriebssysteme finden Sie unter http://www.microsoft.com/mac/.

Könnte mir das vielleicht jemand erklären ??? Oder muß ich die 2.0 und 3.0 deinstallieren,da ja beide Versionen in der 3.5 enthalten sind.

 
Ich persönlich werde NET.Framework 2.0 & 3.0 vorher deinstallieren. Allerdings habe ich bisher noch immer nicht mit letzter Gewissheit herausgefunden, ob die 3.5er-Version die 2.0er- & 3.0er-Version tatsächlich vollständig enthält oder nur die (aus MS-Sicht) wichtigsten Funktionen 'nachbildet'. Die diversen MS-Webseiten sind zu diesem doch wichtigen Punkt immer so eigenartig schwammig formuliert. Schließlich habe ich auch nirgendwo bei MS einen deutlichen Hinweis oder gar eine Empfehlung gefunden, dass man sich durch die Benutzung der 3.5er-Version die beiden Vorgängerversionen jetzt tatsächlich sparen kann. Irgendwie erinnert mich das ganze an die Kompatibilitätsfrage zwischen XP & Vista. Auch dort sollte eigentlich alles was unter XP lief auch unter Vista laufen und viele Programme tun's dennoch nicht. Das 'Warum-nicht' ist dabei aus der Sicht des Anwenders letztlich unerheblich. Die andere Frage ist, ob es auch ein deutsches Sprachpaket fürs 3.5 geben wird.
 
Puuu da ist M$ wieder ein sehr arger Schitzer passiert - Ich habe das NET Framework 3.5 auf 2 total unterschiedlichen Rechner installliert - AMD Nvidia Chipsatz + Intel auf Intel Chipsatz beide auf Vista X 64 - Erfolg: 2 x Blue Screen - Erfolg bei 2 Rechner die Sicherung zurückspielen müssen!

ALSO ACHTUNG
Kommentar abgeben Netiquette beachten!

Video-Empfehlungen

WinFuture Mobil

WinFuture.mbo QR-Code Auch Unterwegs bestens informiert!
Nachrichten und Kommentare auf
dem Smartphone lesen.

Folgt uns auf Twitter

WinFuture bei Twitter

Interessante Artikel & Testberichte

WinFuture wird gehostet von Artfiles