Windows-Bluescreen durch HTML-Code

Windows Luis Alberto Cortes Zavala hat einen neuen Bug in Windows entdeckt. Schon mit einer Zeile HTML-Code kann ein Windows-Bluescreen hervorgerufen werden. Nicht nur ein Reset wird notwendig, auch nicht oder noch nicht vollständig gesicherte Daten gehen ... mehr...

Diese Nachricht vollständig anzeigen.

Jetzt einen Kommentar schreiben
 
lol naja Microsoft kann eben solche sachen erst schliesen, wenn jemand es ihnen sagt^^

thx an hauner für den hinweiss^^
 
@Matze338: http://www.winfuture.de/netiquette.html, Punkt 14. Danke. :-)
 
"Laut einem Test von heise kann es aber nicht nur an Windows liegen: Denn in Firefox Deer Park und in Opera 8.0 konnten die Grafiken unterdrückt oder dementsprechend skaliert werden, sodass es keinen Absturz zur Folge hatte." also woran liegt's dann? Unter Linux gibt's keinen IE. :D
 
@tuxman2: Beim Surfen mit den Browsern Internet Explorer (SP2), Netscape 8.0.1, Firefox 1.0.4 und Mozilla 1.7.8 tritt es auf, wodurch es genau verursacht wird, ist im Moment noch unklar, siehe News. ;-)
 
bis jetzt hab ich ja gedacht hinter Windows steckt n bisschen Arbeit aber durch so ne pillepalle HTML .....
 
@H4sche: Ja klar, viel Arbeit, viele Codes, also viel Angriffsfläche...
 
Es ist schon interessant auf was für Ideen gewisse Leute kommen. Das Problem existiert sicher schon länger, nur ist wohl bisher niemand auf die Idee gekommen solchen "Unsinn" zu testen und/oder zu publizieren.
 
@swissboy: jo, dass hab ich mir auch gedacht hehe
 
@swissboy: Wenn das "Problem" schon länger besteht, frage ich mich warum es keinen Fix seitens M$ hierfür gibt :)
 
@balu2004: Weil es erst jetzt erkannt bzw. gemeldet wurde.
 
@swissboy: naja, leider dürfte das Problem wirklich bereits VIEL länger bekannt sein, denn ich meine mich zu errinnern, dass gerade soetwas früher (und ich meine wirklich früher (5-10 Jahre)) bereits eine Möglichkeit war manche Grafikkarten "abzuschießen". Allerdings wäre folgende Frage interessant, würde mich über tests freuen: Passiert das auch bei ATI-Grafikkarten, da sollte ja eigentlich VPU-Recover dann zuschlagen, oder?
 
Bei den meisten Gamer ist der VPU Recovery das erste was nach dem Treiber installieren deaktiviertt wird.
Ich weiss nur, dass das Ding als es damals neu war, stetig OpenGL Games wie ET abgeschossen hat. Seither habe ich das Ding immer deaktiviert. Ob es inzwischen ausgebügelt wurde, weiss ich nicht, habe aber auch kein Lust es zu testen.
 
@TPW1.5: Ich glaube nicht dass das damals das genau gleiche Problem war.
 
@swissboy: Jein, das Prinzip war das gleiche, den Speicher durch übermäßig große Bilddateien zu belasten. Sprich die Problematik sollte eigentlich bekannt sein ...
 
WAAAS? und das bei jeder windows version oder IE version? das is ja heftig, das werden bestimmt sauviele leute ausnutzen, echt krass - - - edit: mh bei mir passiert garnix, weder IE noch avant... - - - - edit 2: ACHSO, DAS FUNKTIONIERT NUR WENN DAS BILD WIRKLICH EXISTIERT!
 
@HansiHusten: Auch Firefox 1.0.4., Mozilla 1.7.8 und Netscape 8.0.1 sind davon betroffen. Ob das viele ausnützen werden ist schwer zu sagen. Mehr als die Anwender mit einem Bluescreen zu pisacken kann man ja damit nicht. Ich werde dann eine solche Webseite sicher kein zweites Mal mehr besuchen. :-)
 
Hm, soweit ich das verstanden habe liegt das Problem aber beim Internet Explorer und nicht an Windows. Denn FireFox läuft bekanntlich auch auf Windows und nach den o.g. Angaben tritt der Fehler hier nicht auf.
 
@Ketzah: Nein, es scheint an Windows zu liegen, bei Firefox 1.0.4., Mozilla 1.7.8 und Netscape 8.0.1 tritt das Problem ja auch auf. Bei Firefox Deer Park und in Opera 8.0 wurde das Problem einfach schon berücksichtigt indem die entsprechenden Grafiken unterdrückt oder dementsprechend skaliert werden.
 
Mit IE ist der Rechner mit Bluescreen raus, aber mit FF 1.04 und Mozilla 1.77 ging es einwandfrei. Klar kommt man jetzt erst auf solche Ideen. IMO liegt es dran, dass jetzt erst richtig große Grafiken auftauchen und vielleicht man deshalb drauf kam. Außerdem kriegen die Rechner es jetzt schnell hin solche schweren Rechenoperationen auszuführen.
 
Hmmm habs ausprobiert - nichts ist passiert, sowohl im Firefox als auch Netscape
 
@TimeTurn: Gemäss heise ist aber auch Firefox 1.0.4., Mozilla 1.7.8 und Netscape 8.0.1 davon betroffen.
 
@TimeTurn: schau mal o9
 
@HansiHusten: Das kann nicht der Grund sein, denn ich habe eine existierende Datei genommen, guckst Du http://www.zwandula.de/bsod-test.html
 
Die neuen Browser ignorieren diese größe, deswegen funktioniert das nicht.
 
@money_penny: nimm mal ein bild was wirklich existiert, ne url mit jpg oder so, dann wird der rechner mega lahm und nix geht mehr, aber bluescreen kam nich nach 5 mins idlen
 
Nein. Beide sind schuld. OS und IE. Naja wieder ein bugfix mehr für SP3.
BTW :Firefox Deer Park ist doch die 64 bit Varriante von Firefox. Wie verhält sich dieses Problem unter Firefox 32 bit - bzw. aktuelle Version?
 
@cornelis: btw würde mich mal interessieren wie es mit dem Problem aussieht, wenn in der Zeile width="9999998" height="9999998" steht......? :)
 
@cornelis: Nein, Deer Park ist die Entwicklerversion von Firefox 1.1.
 
@cornelis: Wieso bist du so sicher, dass beide schuld sind? SP3? Man denkt wohl eher an einen Patch.
 
@cornelis: Deer Park ist die Entwicklerversion. Die ist einigermaßen stable, aber funktioniert nicht wirklich mit allen akuellen Extensions. Ist ja auch nur eine Alpha für Experimentierfreudige. :)
 
Das ist wohl eher eine Schwäche der Kombination von Windows und Browser.

Die Browser allocieren den Speicher, ohne eben unsinnige Werte zu filtern, und Windows stopft ihnen den Speicher in den Rachen und lagert munter aus. Von Schuld mag man da wohl nicht reden, es wurde einfach nur bisher sowohl von der einen, als auch von der anderen Seite nicht bedacht.

Aber die Problematik an sich ist vielen schon länger bekannt, wurde bisher einfach nur nicht publiziert. Das einzige, was dieses Problem besonders macht, ist die einfachheit mit der man es hervorrufen kann. Man kann diesen Fehler auch mit reinen Jpeg images ohne Skalierung erreichen... (schließlich ist die maximale Größe in jede (sprich 2) Dimension ca 65536) das reicht auch schon um so manche lustigen Sachen mit dem Speicher anzustellen. Firefox filtert nach meiner eigenen Erfahrung Bilder die von der realen größe abnormal sind raus, und läd diese gar nicht erst, aber kleine Bilder extrem hochskalieren geht trotzdem. Bei mir ist IE der einzige Browser, der bei dieser Aktion drauf geht.
 
@katana: Ich teile deine Einschatzung voll und ganz, ausser dass gemäss heise das Problem auch mit Firefox 1.0.4 reproduzierbar zu sein scheint.
 
@ swissboy: Das mag sein, aber unter Linux passiert nichts. Ich tippe auf einen Windowsfehler, gekoppelt mit einem Browser.
 
@money_penny: Sicher ist es ein Windows-Speicherverwaltungs-Problem.
 
@swissboy: wer hätte das gedacht, wir beide gleicher Meinung :) Das das Speichermanagment von Windows ..mmh sagen wir suboptimal ist .. ist eigentlich schon bekannt .. ich kenne einige die machen Nachts ein Reboot von ihren Servern deswegen....
 
ich finds mal wieder armselig das hier manche personen m$ anmachen wegen ihrem code. es sind große programmierer teams die soetwas erschaffen. ein 100% sicheres system gibt es einfach nicht. man kann nicht an alles denken. man sollte froh sein das die service packs die probs beheben und nicht weiter drauf rumhacken. wenn jemand bei microsoft angestellt ist - > Respect!
 
So eine blöde Schwachstelle wäre bald reif für www.daujones.de
 
auf meinem Virtuellen PC WinXP Home + SP2 mit den IE 6 kam es zu keinem absturz... VmWare Version 4.5.2
 
@demmi: Hast du das was unter Kommentar [o9] [re:1] steht beachtet? Hier ist sonst ein Testlink (AUF EIGENE GEFAHR!!!): http://www.gjl-network.de/webhosting/redsun/speicherexp.htm oder http://tinyurl.com/dl5tx
 
@swissboy: boah das bild ist 110GB groß und er zeigt es trotzdem an ?! wo er das wohl hin tut? so eine große auslagerungsdatei hab ich doch gar nicht :/
 
also bei mir passiert da nix... ich hab das grad auf ner VMmachine getestet und nix is passiert... sowohl im IE als auch FF
 
@daff: Veilleicht ist die Speicherverwaltung unter VMmachine auch etwas anders. Siehe auch Kommentar [14] [re:1].
 
@swissboy: klein hinweis, nicht auf unbedingt jeden eingehen, sonst hassen die dich wieder.
 
@zauberer: ich mag swissboy ^^ ... und finds gut, dass er jedem ne Antwort gibt *daumenhoch*
 
ich glaube kaum das diese schwachstelle kommerziell ausgenutzt wird, mit blue screens kann man nichts verdienen. ich könnte mir maximal denken das man über schadsoftware blue screens auslösen möchte.
 
@zauberer: Böse wäre das, wenn man das irgendwie ausnutzen könnte, um Schadcode auszuführen...wer weis...dann gäbe es da sicher interessenten für
 
ich habs auch getestet. Mit FF keine Problem. IE 6.0 SP2 nach ein paar sek Bluecreen.
Wers probieren will: http://www.apache-root-server.de
 
@Apache: ich ahnte schon das deine URL auf so ein bild abziehlt und nahm extra opera ! wenn du schon ein link postest wo man die schwachstelle daran nicht sehen kann, dann warne die leute wenigstens !
 
@zauberer: hatte ich doch. wollte es nur mal probieren. und hab dort eine index hingelegt und ein winfuture pic. aber ne warnung wäre nicht schlecht. stimmt :)
 
@zauberer: ich glaube er hat das deutlich gemacht :-) @apache: was ist das, ein riesen Winfuturewsicon? "fg" edit... ne, steht doch windows drauf... @zauberer: doch, du kannst es verkleinern, rechte maustaste, bild anzeigen :-)
 
@money_penny: ohne dem hinweis das über die hauptseite schon das verzerrte bild dargestellt wird ist nichts deutliches erkennbar.
 
So eine Warnung mit Verweis auf WF ist eingebaut :D
 
@swissboy danke für den testlink...mitm FF hab ich hänger aber keinen bluescreen...mitm IE hab ich schlimmere hänger aber auch keinen bluescreen... naja egal windows laft weiter HEHE :)
 
@The Master: Unter Linux passiert nichts. Keine Hänger, wird nicht langsam... als ob nichts wäre.
 
@money_penny: Da wäre auch ein riesiger Zufall wenn das genau gleiche Problem auch unter Linux auftreten würde.
 
Weder IE SP2 noch Firefox Bluescreen. IE lädt das Bild garnicht, stellt zwar ein Frame für das Bild zur Verfügung (man siehts an den Scrollbalken), lädt das Bild aber nicht. Firefox lädt das Bild, wird beim scrollen schnarchlangweilig, stürzt aber auch nicht ab.

Für diejenigen, die Probleme haben: Das muss an einer schwachen JPG-(oder andere Dateiformate)Lib liegen, die im System integriert ist, und auf die sowohl Netscape als auch Firefox und IE zurückgreifen. Da Opera (und offensichtlich auch Deer Park) seine eigene libjpg hat, tritt der Fehler dort nicht auf.
 
@DC|Scream: kannst du auch sagen warum bei dir kein systemabsturz erfolgt (vorrausgesetzt deine info ist korrekt )?
 
@DC|Scream: Ich glaube eher das was in der News steht. Bei Firefox Deer Park und Opera 8.0 wurde das Problem bereits berücksichtigt indem die Grafiken unterdrückt oder dementsprechend skaliert werden.
 
@DC|Scream:
Gecko benutzt schon immer (seit Mozilla M0.1) unter windows seine eigene imagelibs.
Die aktuelle heißt implementierung libpr0N : http://www.libpr0n.com
 
mh... hab grad den link von Apache ausbrobiert... windows ist zwar merklich langsamer geworden und er hat nur den anfang des bildes gezeigt, aber zum bluescreen ist es auch nach 15 min. nicht gekommen. kann es von der größe des rams und der auslagerrungsdatei abhängig sein?
 
@crashxp: Es sieht fast so aus wie Absturz bzw. nicht Absturz von mehreren Faktoren abhängt.  PS: Dein Nickname passt zu dieser News. :-)
 
@crashxp: ich habe es auf einem Testrechner probiert. P3 1000 mit 512 MB ram. alle einstellungen standard (auslagerungsdatei). Nach ca 20 sek kommt ein Bluescreen. könnte ja wirklich mit den Einstellungen zusammenhängen.
 
Jo - bei meinem Desktop-PC geschieht absolut nichts. Mein Laptop hingegen erfährt gerade seinen ersten Windows-Bluescreen (wie schääh). Beide XP-SP2 all Updates. Habe es ein paar mal getestet.
 
Auf Laptop mit P-M 1600 und 512 MB Ram (SWAP 1024) Absturz nach ca. 20 Sekunden bei Firefox und IExplorer / Auf P4 3200 @ 3800 und 2048 MB Ram (SWAP 4096) Bildaufbau nach ca. 6 Minuten bei Firefox und IExplorer.

Scheint echt an der Konfiguration und Rechnerleistung zu liegen.

Gruß,
Soulreaver
 
Also diese Info hab ich schon über vodafone wap um 10Uhr mit Handy abgerufen. Manches steht hier nen Tag später als bei golem oder heise :-)
 
Mit VMware und installierten Windows xp sp2 und Firefox kam auch ein Bluescreen. Hoffentlich wird der Fehler bald behoben.
 
Hallo
So neu ist der auch nicht.
Genannt HTML kill WINDOWS
Den Link hatte ich scon am 24.05 hier mal gepostet.
Selbst bei dieser Seite machte sogar Linux schlapp.
Grund weil das Bild ausgelagert wird und im Speicher reproduktziert wird, was zu einem total Ausfall führt.Man kann diewerse Änderungen im HTML Code machen, was wiederum ein Systemabsturz zu Folge hat.
Ausserdem wurde in der Newsgroup d.c.s.m am 23.05 ausführlich und in diversen IT Chst und Groups über Lösungen gesprochen.
Also kann man den Code je nach Browser und System verändern und anpassen was einer DDOS Atacke gleicht.

Schönen Abend noch.
 
@Linuxkiller: "Selbst bei dieser Seite machte sogar Linux schlapp." ... Das möchte ich sehen.
 
@Linuxkiller: Ich mag mich schwach erinnern. :-)  Hast du den Link noch?
 
@Linuxkiller: Na wenn wir schon dabei sind: http://www.eggdrop.ch/fun/crash/ ... AUF EIGENE GEFAHR ein paar nette Spielereien.
 
@Linuxkiller: Habs gerade mal mit SuSE 9.3 gecheckt. Wo bitte soll hier das Problem sein?? Kernel 2.4.31!
 
@Ice-Tee: Suse/Linux selbst wird wohl nicht abstürzen, aber den Browser kann man mit kleine Java-scripten schon zum Absturz bringen.
 
@money_penny: Der Link von Linuxkiller war aber ein anderer oder täusche ich mich da?
 
@swissboy: Ja, ich denke schon das er was anderes meint. Aber er redet ja nicht mit uns :-)...
 
@money_penny: Aber das liegt dann wohl am Browser, und nicht an Linux.
 
Funktioniert bei mir nicht.
Weder unter Firefox, IE oder Netscape konnte ich einen Bluescreen oder einen Systemabsturz produzieren.
Nur der jeweilig verwendete Browser beginnt instabil zu werden bzw. hängt sich auf.
Aber selbst dann, kann ich ihn noch ganz normal schließen.

Eigenartig...
 
@Sir Richard Bolitho: Wie obigen Kommentaren zu entnehmen ist hängt die ganze Sache wohl auch mit verschiedenen Systemkonfigurationen zusammen.
 
@swissboy: Vermutlich ist der Grafikkartentreiber schuld. Im Heise Forum haben nen paar angefangen, die Crashdumps zu debuggen. http://tinyurl.com/da6sb
 
@Smurfy: Ich tippe auch darauf das es mit dem Grafikkartentreiber oder der Grösse des Grafikkartenspeichers zu tun hat. Auf einem Rechner konnte ich es reproduzieren und da hat er im Bluescreen auch etwas gemotzt welches auf die Grafikkarte hindeutete.
 
mit "winternals crash analyzer wizard" aus dem administrator pak2005 kann man minidumps problemlos auswerten lassen .
 
@Sir Richard Bolitho: Ich konnte auch keinen Bluescreen produzieren, auch bei mir wurde der Browser nur sehr träge, aber mit ALT+F4 konnte ich den Browser (mit etwas Geduld) schließen.
 
Ich hab diesen Bug im Firefox IRC-Channel vor einer Woche zur Sprache gebracht. Kommentare waren unter anderem "...bei mir nicht" oder "unwichtig" usw. Endlich mal von "offizieller Stelle die Bestätigung". Bei einem Notebook mit ATI-Graphikkarte übrigens ein Bluescreen des Treibers.
 
@AleXP:
Dann lass mal Deinen Treiber fixen.
Wenn FF zuviel Memory allocated, dann ist das eine Sache die man evtl vermeidet aber
ein BSOD eines Treibers ist das Problem des Treibers.

Und außerdem ist das schon lange gefixt (und ich rede nicht von Deinem FF1.0.X mit einem über 12 Monate altem Gecko)
 
Na Mal heissen Dank für die Lösung, brauch ich nicht weiter rätseln. Wollt meine Gurke schon neu aufsetzen.
 
@swissboy: Hmmm, wenn ich Deine URL aufrufe wird zwar Firefox für einige Sekunden sehr träge, dann gehts aber. Laut Taskmanager wird zwar noch Speicher aufgebraucht und die CPU-Auslastung ist auf 100% - der Speicher war aber nach 5 min immer noch bei ca. 600 MB freiem Speicher....da war also lässig Zeit, um den Tab mit der URL zu schließen, bevor da überhaupt was passieren kann +++- ich vermute mal, das liegt daran, das ich 1GB RAM hab und nen Athlon 64, der mit seinem NX-Bit vor Pufferüberläufen schützen dürfte(?) +++ müsste glatt mal die URL mit meinem SonyEricsson P900 und den darauf installierten Opera Browser für Symbian-OS UIQ ausprobieren :)
 
bei mir ist weder im IE 6. noch im Firefox 1.0.4 etwas passiert ausser dass er wirklich in die knie ging beim laden, aber man konnte die beiden browser ohne probleme schließen.
 
dann warte beim IE mal auch wirklich ne Minute oder so länge. Der kriegt echt einen BlueScreen, aber es dauert, bis er das Ding lädt.
 
wie schaut's eigentlich mit bösen html mails aus? hat das schon jemand probiert? :-)))
 
Hi @all,

hab jetzt mal bei Heise wieder nachgelesen, was die Leuts so meinen. Die Darstellung des Problems klingt sehr einleuchtend. Ich mache mir momentan Gedanken um die klugen Köpfe die sich jetzt schon ausmalen, wie es mit der Hochsetzung von anderen Größenangaben aussieht. Egal ob jetzt in HTML oder anderem Code. Alles was den Speicher zuhaut, egal ob Grafikspeicher oder Arbeitsspeicher ist Gift für Windows.

Sobald Windows nicht mehr Herr über die Lage wird, kommt der BSOD. Gut das auch manche Linux Systeme betroffen sind. Ansonsten würde es wieder heissen, guckt Euch die Windows User an, wieder ein Bug der uns nicht betrifft. Stattdessen dürfen die sich jetzt auch mal mit so nem Mist vergnügen.

Was sagt uns das ? Jedes System hat seine Schwachstellen, das eine mehr, das andere weniger :o)

 
Ich finde M$ toll. Die machen jeden glücklich: Die Windows-Fanboys und die Hasser auch - bei so ner Zielscheibe kann man nicht danebentreffen. :P Die Windows-Speicherverwaltung ist allerdings nicht das gelbe vom Ei, und die Prozeßverwaltung auch nicht. Wie kommt es sonst, daß manche Prozesse das (Pseudo-) Multitasking von Windows so lahmlegen, daß man nur zugucken und warten kann, bis der Prozeß fertig ist? Nee, nee, ich werde den Verdacht nicht los, daß bei M$ zu viele Amateure am Werk sind. Alleine, wenn ich mir die MSVC IDE oder Source Safe anschaue, kringeln sich mir die Zehennägel, so oft habe ich mich schon über manchen Unfug darin geärgert. Ich bin übrigens eingefleischter Windows-User. :P
 
Um mal etwas klarzustellen: Der Fehler liegt im Grafiksubsystem von Windows bzw. den Grafiktreibern, ebenso ist so mancher X-Server betroffen. Das Problem ist, daß das Skalieren von Pixelgrafiken von den meisten modernden Grafikkarten in Hardware implementiert ist und deshalb an die Grafiktreiber delegiert wird - die wiederum alloziieren dann sehr viel Speicher und bringen, wenn sie im Kernelmode laufen (was halt auch einige 3D-beschleunigte Treiber unter Linux tun), halt das ganze System zum Absturz. Deshalb sollten Webbrowser auf solche optimierten Delegationen seitens des GDI verzichten und eventuell Paramater etwas pragmantischer validieren.
Kommentar abgeben Netiquette beachten!

Video-Empfehlungen

WinFuture Mobil

WinFuture.mbo QR-Code Auch Unterwegs bestens informiert!
Nachrichten und Kommentare auf
dem Smartphone lesen.

Folgt uns auf Twitter

WinFuture bei Twitter

Interessante Artikel & Testberichte

WinFuture wird gehostet von Artfiles