WinXP SP2: Schwerer Bug mit AMD64-Systemen

Windows Wer einen AMD Athlon 64 bzw. Opteron sein Eigen nennt und das Service Pack 2 für Windows XP installiert hat, kommt in den Genuss der Data-Execution Prevention (DEP). Damit soll verhindert werden, dass Viren bösartigen Code im Falle eines ... mehr...

Diese Nachricht vollständig anzeigen.

Jetzt einen Kommentar schreiben
 
lol er hat aber wirklich recht. es ist doch lächerlich was die da programmieren. und das war GANZ SICHER nicht der einzigste bug. ich persönlich habe auch schlechte erfahrung mit dem sp2 gemacht. ich kann erwarten das meine software besser wird durch solche patches und nicht neue fehler wie diese hinzu kommen. daher kann man wirklich nur sagen, dass man abwarten sollte bevor man einen patch von ms installiert!
 
@XDestroy: Ein Großteil der Probleme, die mit dem SP2 bestehen, ist aber auf inkompatible Software von Drittanbietern zurückzuführen.
 
TiKu, Komischerweise war die inkompatible Software vor dem SP2 noch kompatibel... was nu?
 
@paul_panther07: Gab es vor dem SP2 NX/DEP? Nein! Also hat das keine Aussagekraft. NX/DEP arbeitet so wie es soll - es verhindert, dass Daten ausgeführt werden. Programme, die unsauber geschrieben sind und mitunter Daten ausführen, funktionieren mit NX/DEP logischerweise nicht mehr. Also ist es Schuld der Dritthersteller. Hätten diese nämlich von Anfang an sauber programmiert, gäbe es jetzt keine Probleme.
Du forderst dagegen scheinbar, dass solche unsauberen Sachen auch mit NX/DEP noch funktionieren und stellst NX/DEP damit komplett in Frage.
 
@XDestroy: Ja aber es sollte nachher besser laufen als vorher und nicht schon wiede rProbleme machen. Das ist es was die auffe Reihe kriegen sollen! Sorgfältiger prüfen. Bevor es an die öffentlichkeit geht!
 
@XDestroy: Ihr versteht's nicht... MS hat im Grunde alles getan was zu tun war. Man hat die Entwickler frühzeitig (glaube im Herbst 2003) darauf hingewiesen welche Codekonstrukte mit dem SP2 nicht mehr funktionieren werden und hat auch Lösungsansätze geliefert. NX/DEP funktioniert wie es soll. Was sollte MS noch tun? Für jede Problemsoftware eine Ausnahmebehandlung einbauen? *lol* NX/DEP aufweichen? Dann kann man es auch gleich rauslassen.
 
@Tiku: Komisch nur, daß ausgerechnet M$-Software wegen DEP abstürzt ... ich habe deshalb sogar einen Hilferuf im WinFuture-Forum losgelassen. Z.B. stürzt mit SP2 die integrierte Hilfefunktion von WinXP ab, und das Security Center tut desgleichen ... :P
 
@TiKu: Du scheinst nicht zu verstehen welche Verantwortung hier MS trägt. Es ist ein großer Fehler und es funktioniert nicht wie es soll. Diese Fehler muss jetzt mit einem Patch behoben werden. Und genau das hätte MS vorher machen müssen. Diesen Fehler hätten die Vorher ausmerzen müssen bevor jemand damit konfrontiert wird. Denn da wäre man doch bis man den Patch hat ohne SP2 besser dran. Und das ist es was nicht in Ordnung ist von MS!
 
@XDestroy: Was an NX/DEP funktioniert denn nicht wie es soll? Kannst Du mir das verraten? @Aspartam: Das kann auch andere Ursachen haben. Du bist der erste mir bekannte, bei dem Hilfe und Security-Center nicht laufen.
 
@TiKu: Les doch einfach die News. Dort steht es! Und das reicht schon aus! Du verteidigst MS hier Grundlos!
 
@XDestroy: Die News ist irreführend! Nicht NX/DEP hat einen Bug, sondern Mpegport.sys. Nochmal langsam für Dich: NX/DEP verhindert, dass Bereiche des RAMs, die Daten enthalten vom Prozessor als Code ausgeführt werden. Da viele der Würmer sich Buffer Overflows zu Nutze machen, bei denen Daten ausgeführt werden, verhindert NX/DEP also, dass sich Würmer verbreiten. Es gibt aber auch Programmiertricks, die ebenfalls Daten ausführen. Diese gehen logischerweise auch nicht mehr. Wenn Mpegport.sys nun einen ebensolchen Trick nutzt, greift natürlich NX/DEP ein, denn genau das ist seine Aufgabe. Das Eingreifen heißt normalerweise, dass das Programm beendet wird. Bei einer Systemdatei kann es dadurch aber auch zu einem Bluescreen kommen.
Nun kapiert?
Auf Planet 3DNow! ist die News übrigens korrekt, da steht dass die Mpegport.sys verantwortlich ist und nicht NX/DEP.
 
@XDestroy: in der vergangenheit hat microsoft immer auf abwärtskompatibilität geachtet, und somit auch sicherheitslücken immer mit durchgeschleift. mit der aktuellen situation von viren/trojanern.. etc. waren sie dazu gezwungen alles in richtung sicher zu machen... zum ersten mal in richtung sicherheit und nicht in richtung abwärtskompatibilität. du hast eigentlich ein neues betriebssystem vor dir.. stell dir das einfach vor.. wenn bei longhorn irgendwas net mehr läuft jammerste doch auch net oder? ich finde microsoft hat den trend schon richtig erkannt, das sicherheit wichtiger ist, als das noch alles läuft. es gab genug beta versionen.. frühzeitig, so das alle hersteller auf die neue situation reagieren konnten. daher ist diesmal der fehler auch nicht bei microsoft zu finden... finde das ganze von microsoft diesmal sehr gut gemacht. frühzeitig öffentliche betas... interne betas.. alle entwickler konnten genug testen ob es noch läuft, und software anpassen... es wurde sehr viel aufwand von seiten von microsoft betrieben. das es immer noch sicherheitslücken gibt, war eigentlich auch klar... aber.. da in allem sicherheitslücken vorhanden sind... braucht man ms nicht den größten vorwurf zu machen... und weil hier geschrieben wurde, microsoft hat die pflicht das alles läuft... erst wird gejammert das es ja soo unsicher ist.. alle jammern nur darüber.. dann machen sie was dagegen, und dann ist auf einmal die pflicht das noch alles läuft.. leute, alles geht halt nicht... aber der bug der hier in den news beschrieben wurde, hätte man in der beta testphase wirklich finden müssen.
 
@Aspartam: "z.B. stürzt mit SP2 die integrierte Hilfefunktion von WinXP ab, und das Security Center tut desgleichen ..." Kann ich beides nicht nachvollziehen. Funktioniert bei mir alles bestens. Oder habe ich nur Glück!.
 
@XDestroy: Tja. Das weißt Du genauso gut wie ich das SP2 erst in the wild "getestet" werden muß, um klare Aussagen machen zu können wo wirklich die versteckten Macken liegen. Das weiß jeder hier. Da interessiert auch kein noch so große Betatest-Vorlauf.
SP2 mußte auf diverse DAUs und den "Semi-Profis" losgelassen werden. LEIDER(!)
Bis Ende des Jahres wird sich die Lage da auch nicht beruhigen. Meine DVB-Karte produziert unter SP2-RTM auch noch Netzwerk-Macken. Das sind keine Software-Fehler vom Hersteller mehr, sondern Windows-Aussetzer. Das war nur eine Frage der Zeit, bis der Großteil der User merken würde das da noch einiges im Argen liegt. Da es aber angedroht war größere (?) Spezifikationsänderungen durchzuführenn reg ich mich deswegen jetzt auch nicht mehr allzusehr auf. Da hilft nur Abwarten. Das Patchen geht wieder los. Diese Welle hast Du mit Installation des SP2 nicht etwa hinter Dir. Sie hat gerade erst angefangen. Von Dir sollte man es (oder etwa nicht - dann sag es gleich) doch erwartehn können, das Du da sachlich bleibst. Auch wenn von mir nochmal: das ist nicht nur "XP-SP2" sondern viel mehr "Windows XP TE (Third Edition nämlich)"... Unter der Haube ist viel passiert. Sehr viel sogar. Und dabei ist die Frage nicht mal "war das zuviel ?" - sondern ganz klar "war das endlich genug ?"
 
Das blöde Gelabber steckt eigentlich im WinFuture Artikel selber. "Ausgerechnet dieses sinnvolle Feature ..." als ob das so tragisch wäre. Es ist eben ein neues und praktisch unerprobtes Feature. Was solls? Kommt es eben etwas später. Wo Microsoft sich blöd anstellt, ist bei der Behebung von Bugs, nachdem sie bekannt wurden. Fehler passieren auch den Besten und da sollte man Microsoft nicht ausgrenzen.
 
@sdack: Ich fürchte XP-SP2 droht dasselbe Schicksal wie XP-SP1. Das hatte zuviele Security-Lecks. (wenn auch schon erheblich weniger als die Initialversion).
Tja - bis SP3 stehen uns dann wohl diverse "Compatibility-Hotfixes" ins Haus.
Und natürlich auch solche Fixes die die generell neuen Features vom SP-2 betreffen.
Das System ist viel zu oft jetzt umgekrempelt worden, um nach SP-2 sagen zu können das dieses das das letzte große Mayor-Update für XP war. Meine Meinung zumindest.
Und die hätte ich auch wenn es jetzt nicht diese Startschwierigkeiten geben würde -
denn genau unter diesem Punkt sind solche Probleme einzuordnen. Der September-PatchDay ist zum Glück soweit nicht mehr entfernt. Das sind ja nur noch knapp 2 Wochen...
 
hab nen amd 64 aba noch ncih das sp2 draufgemacht
 
Ich hab nen AMD64 und das SP2 drauf! Bis jetzt noch kein Problem gehabt,
aber hoffentlich stellen die bald den Patch fertig!
 
@John-C: Es trifft nur AMD64-Systeme mit einem Hardware DVD-Decoder. Andere Systeme haben die Datei scheinbar gar nicht.
 
Wann kommt denn SP3 *lol*
 
wenn du ein problem hast kannst ja umsteigen :)
Microsoft gibt sich mühe und einige haben nichts anderes zu tun die zu verarschen ach ja Microsoft arbeitet nicht nur an "xp"
und die haben viel zu tun mit "Longhorn"
Wenn ihr nicht damit zufrieden seit ______->"Linux"!
 
scheinbar tritt der Fehler nur auf, wenn man einen Hardwarebeschleuniger für MPEG-Encoding als PCI Karte im Rechner hat... und das wird wohl nicht auf besonders viele Leute zutreffen...
 
den bug oder einen ähnlichen hatte ich schon bei der rc1 eingesendet
 
und jeder wird auch nicht einen 64er haben, denke ich
 
bin ich froh daß ich es auf meinem 64er-System noch nicht installiert habe. Zunächst funktionieren Programme nicht mehr jetzt werden die ersten Bugs bekannt. Was kommt als nächstes. Vielleicht zieht Microsoft ja das Service Pack 2 ja wieder zurück :)
 
@assman: Wieso sollte MS es zurückziehen? Dass Programme nicht mehr funktionieren, liegt idR daran, dass sie inkompatibel zu NX/DEP sind. NX/DEP selbst arbeitet wie es soll, deshalb gibt es keinerlei Grund, das SP2 zurückzuziehen.
 
das ist mir schon klar, daß Microsoft es nicht zurückzieht.
Aber wenn der Fehler schon im RC1 bekannt war warum wurde er nicht
beseitigt.
 
@assman: Berechtigte Frage. Vll. ist beim Bugreport etwas schiefgelaufen. Vll. wurde er einfach übersehen. Keine Ahnung...
 
also ich hab auch zwei amd64 systeme bei mir daheim stehen und auf beiden das sp2. alle beide laufen super. ich denke es ist mal wieder so was, was nur in ganz bestimmten konfigurationen und wenn man was ganz bestimmtes macht, auftritt. und nu denken einige gleich wieder das ist bei allen so. es ärgert mich immer, wenn wieder ein fehler bei microsoft gefunden wurde das alle(fast) dann gleich schreien scheissladen. zeigt mir doch mal ein programm welches perfekt ist(vorallem eins mit solchem umfang). ständig kommen für alle möglichen programme patches raus. ich bin vollauf zufrieden mit dem sp2. viele grüße
 
Langsam wird blöde... man wartet auf ein Servicepack und hofft, das sein System nach dem Aufspielen noch läuft.... Dann muss man feststelle, dass danach bestimmte Software nicht mehr läuft... ein paar Tage dann die Liste der Software, die Ärger macht... man faßt sich doch langsam am Kopf und fragt sich ernsthaft, ob man sich das alles gefallen lassen muss. Ich habe es langsam wirklich satt mir immer und immer wieder irgendwelche Patches gegen Patches zu ziehen... Ich fühle mich verarscht.
 
@paul_panther07: s. oben, die meisten Beschwerden über das SP2 sollte man an die Hersteller der Software auf besagter Liste richten.
 
TiKu:... und da MS selbst zu den unsauberen gehört (ich kenne die Liste), liegt für mich die Schuld beim Betreibssystemproduzenten. Die haben einfach mal richtig geschlampt .. die "anderen" sind jetzt die Bösen, war doch klar... ich brauch im übrigen kein NX/DEP, wozu auch? Läuft auch prima ohne...
 
@paul_panther07: Sie haben AUCH geschlampt, sind aber bei weitem nicht die einzigen. Das wollen wir mal nicht unter den Teppich kehren.:) Wozu Du NX/DEP brauchst? Schalte es ab und warte auf den nächsten Wurm, der sich über einen Buffer Overflow einschleicht. Während NX/DEP-Nutzer dieser Wurm kalt lässt, ist Dein System gefährdet und muss mit Firewall u. ä. extra abgesichert werden.
 
@paul_panther07: Nachtrag: Wobei MS nicht beim OS geschlampt hat, sondern bei den Anwendungen (Visual Studio, Office usw.)
 
@Winfuture: "Ausgerechnet dieses sinnvolle Feature enthält einen schweren Bug." Falsch! NX/DEP arbeitet korrekt! Der Bug liegt in der Mpegport.sys!
 
Geil... vor allem weil die das SP2 ja komplett mit VS.NET 2003 durchkompiliert haben, wo sowas gar nicht auftreten sollte und vor allem das Segment durch den Linker eigentlich auch korrekt getaggt sein müsste. Wie haben die das nur angestellt?
 
Sorry, ich habe einen FSC Scaleo AMD Athlon 64, aber das geschilderte Problem ist bei mir nicht aufgetreten. Allerdings hat sich der Rechner nach der Installation von SP2 beim Shutdown nicht mehr ausgeschaltet.
Lösung brachte nach Rückfrage bei FSC dann endlich ein Bios-Update und alles schnurrt....
 
Ich war anfangs auch skeptisch gegenüber dem SP2. Begründet war dieses durch die ganzen (eigentlich vollkommen unprofessionellen) Begründungen der ganzen Leute hier. Aber dann habe ich mir die Erfahrungen von Leuten angehört, die wissen, wovon sie reden. Nun, SP2 installiert, und habe nix bereut. Das System scheint agressiver zu reagieren, hatte keinerlei Probleme mit jeder Software. Dass das MS OS Bugs hat, is schon klar, aber ehrlichgesagt merke ich im Alltag nix von und ich nutze meinen PCmehr, als manch anderer otto-normal user :)
 
@NewsLeser Begründet war dieses durch die ganzen (eigentlich vollkommen unprofessionellen) Begründungen der ganzen Leute hier:

Daher: microsoft.public.de.german.windowsxp.setup und sich von dort von einem MVP aufklären lassen
 
bluescreens starten den rechner NICHT automatisch neu....gott schmeiss hirn vom himmel....dafuer gibt's ne option....
 
@Bogy: "Da unter Windows XP bei einem Bluescreen _standardmäßig_ der Rechner automatisch neu bootet..." Wer lesen kann... :) Es ist die default Einstellung.
 
@netwolf :
...und wer seinen pc einstellen kann ist auch klar im vorteil....das ist das erste was man aendert...ausserdem ist's kein sp2 fehler und ausserdem gibt's immernoch bootmoeglichkeiten ohne die option abzustellen.
 
könnte es vielleicht jemand kurz erklären??
 
Wüßte auch gerne, wo das einzustellen geht. Allerdings kann ich mich auch nicht dran erinnern, unter XP jemals einen Bluescreen oder Neustart erlebt zu haben.
 
@StH2003: Systemsteuerung -> System -> Erweitert -> "Starten und Wiederherstellen" (ganz unten) -> Einstellungen -> "Automatisch Neustart durchführen"
 
Also auf meinem 64 Schlepptopf läuft das SP2 ohne jegliche Probleme und auch auf den Athlon XP Rechner habe ich keine Probleme gehabt, weder beim updaten noch danach und ausserdem kann man doch (DEP) abschalten, und warten bis ein Patch für die MPEG Decoderkarte da ist.
 
Angeblich sind es noch viel mehr Programme, die nach dem SP2 nicht mehr funktionieren sollen. Noch schlimmer, es geschieht absichtlich! Diversen Gerüchten zu Folge, sind vor allem Viren und Würmer davon betroffen.
 
@sdack:in der Tat: Viren und Würmer sind auch Programme, aber wenn die nicht mehr funktionieres isses doch gut :-))
 
hilfe... ich hab meinen virenscanner geupdatet, auf einmal läuft mein Sasser nicht mehr... *flam* mann mann mann... eine kleine option, die den fehler aufhebt... ist doch verkraftbar... wenn man überlegt, was man bei anderen OS'es alles von Hand einstellen muss, damit kleinigkeiten laufen... dann ist das hier wohl seeeeehr leicht zu verkraften.
 
Welcher Virenscanner soll das sein? Also mein Sasser läuft noch einwandfrei. (ernsthaft!)
 
@NewsLeser: Diese unprofessionellen Aussagen kommen von MS-Hassern oder Leuten die es einfach cool finden gegen MS zu wettern.
 
ich kann es nicht bestätigen habe SP2 seit Sonntag drauf und auch AMD64 aber noch kein einzige Bluescreen gehabt auch kein hänger.

Das einziger problem was ich hatte war das mir der PC nicht vollständig runtergefahren ist und ausgeschaltet hat aber das hat mit FSC Board 1607 zu tun gehabt, nach dem Update des Bios geht es alles problemlos
 
@Bessi: siehe Post 17 re 1
 
@Bessi: sorry, meine natürlich Post 16
 
Geht mit wie @Besi zumal ich diese Datei überhaupt nicht habe.

 
Tiku arbeitet wohl für MS, so wie er die verteidigt *lol*
 
@666pinhead: Nein, ich arbeite nicht für MS. Mir geht aber dieses ständige Gemeckere über MS auf den Sack. Ist das Verboten? Wenn über andere Firmen zu Unrecht gemeckert wird, verteidige ich die auch. Aber ich weiß schon, ich hasse MS nicht, also kann ich nur für die arbeiten. Naja, auch Du wirst das Kindergartenalter irgendwann überwinden (hoffentlich).
 
Traurig ist es schon dass mann erst rumfumeln darf das der Knecht wieder löppt. besitze nämlich auch ein 64er grrrrrrrr.
 
So wieder! HM =)
 
tja...wer sich ein computer zulegt muss sich im klaren darüber sein das er "nichtmehr" mit sandförmchen ausn sandkasten spielt ! :))....@TIKU mir gehts genauso , ich hatte das schon nach dem SP2rc1 kommen sehen das die meisten bugmeldungen nur geschwätz sind nachdem ich einiges in offenen M$ foren gelesen hatte....und du weisst ja wie das mit gerüchten ist, die verbreiten sich schneller als die wahrheit.
 
**********************************************************
Das Neustartproblem kann ich auf meinem Rechner reproduzieren, aber diese Datei ist nicht auf meiner Festplatte. Es muss noch andere Situationen haben, die diesen Effekt auslösen. Also vorsicht! :-)

P.S. In diesem Forum habe ich oft das Gefühl, das erklärte Ziel ist es, sich gegenseitig an Infantilität zu übertreffen. Im Vorschulalter hatten wir auch solche Diskussionen in dieser Art geführt.
 
@ralphberner: "P.S. In diesem Forum habe ich oft das Gefühl, das erklärte Ziel ist es, sich gegenseitig an Infantilität zu übertreffen. Im Vorschulalter hatten wir auch solche Diskussionen in dieser Art geführt." Das wundert Dich wirklich? Es gab hier mal eine Alterstatistik der Mitglieder... und: Zurückgebliebene gibt es überall
 
Leute Leute, ich weiß nicht was Ihr alle habt. Ich besitze auch einen 64er AMDAthlon, und ich habe das SP2 für IT-Professionals drauf seit dem es für die Betatester freigegeben wurde. Und was soll ich sagen es läuft einwandfrei, keine Abstürze und was mich besonders Wundert, das ich einige der Programme die in der „(In-)Kompatiblitäts-Liste“ stehen auf der Platte habe, und oh Wunder sie funktionieren alle einwandfrei. Wobei ich aber sagen muss, dass ich die Feststellung gemacht habe, es scheint so zu sein, dass wenn man die SP2 auf ein bestehendes System aufsetzt, das dann alle Programme funktionieren. Aber wenn man neu mit SP2 installiert und dann die Programme aufspielt, dann funktionieren sie wirklich nicht. Habe ich jedenfalls beim Office 11 festgestellt.
 
@Unimatrix-Siro: "Aber wenn man neu mit SP2 installiert und dann die Programme aufspielt, dann funktionieren sie wirklich nicht. Habe ich jedenfalls beim Office 11 festgestellt." Kann ich so nicht bestätigen, habe nach SP2 auf meinen AMD64 mehrere Programme aufgespielt und keine Probleme feststellen können. Ich meine aber, dass je nach individueller Rechnerkonfiguration durchaus Probleme auftreten "können", die jedoch in der Regel lösbar sind. Ferner beachten viele nicht die bekannten Installationshinweise wie z.B. Hintergrundprogramme (insbes.Virenscanner) etc. vor der Inst. von SP2
zu deaktivieren
 
Kann das hier nicht glauben. Ich hab keine Probleme (WinXP SP2 + AMD64) und hab noch nicht mal eine Datei Namens mpegport.sys!!!???

Was stimmt hier nicht?
 
@Shaolin7: Du hast keinen Hardware-DVD-Decoder. So einfach ist das.
 
Tja hm,..

war schon am verzweifeln :D dachte hardware is platt gewesen oder so,..

dieses problem hatt ich nämlich :/ nach 10 mal windows neu nistallieren irgendwann mal faxen voll gehabt,..
 
also geb ich meinen senf auch mal dazu:ich war mit dem SP2 EIGENTLICH zufrieden.....bis auf:race driver 2 liess sich ums verrecken nicht mehr online spielen..(timeout)hab auch mit nem tool die verbindungen auf 50 erhöht..aber es funzt nicht...und bei call of duty(funzte immer noch einwandfrei)konnte ich zeitgleich nicht skype laufen lassen,da sonst call of duty rukkelte(online..is klar oder)..hab dann SP2 deinstalliert und siehe da....alles funzt wieder!!!achso:leitung is die 2000erDSL und meine maschine ist amd athlon 64 3200+...
 
aber irgendwie passt das da nix rein komischer weis!
 
@TiKu: Dann sollte das aber in den News mal erwähnt werden :-) Sonst kriegt man hier noch das Gefühl von Tatsachen-Verdrehung :)
Kommentar abgeben Netiquette beachten!

Preisvergleich Phenom II X4 965 BE

AMDs Aktienkurs in Euro

AMDs Aktienkurs -1 Jahr
Zeitraum: 1 Jahr

WinFuture Mobil

WinFuture.mbo QR-Code Auch Unterwegs bestens informiert!
Nachrichten und Kommentare auf
dem Smartphone lesen.

Folgt uns auf Twitter

WinFuture bei Twitter

Interessante Artikel & Testberichte

WinFuture wird gehostet von Artfiles